How can we improve the customer self service Apps?

Thermostat Control from the App

a no brainer; Pepco.....

38 votes
Vote
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
You have left! (?) (thinking…)
zebonaut shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

35 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    PEPCO app worked on both iPad and iPhone, but then stopped working on just my iPhone. Got the “oops” error message.
    Deleted PEPCO app from iPhone (as someone in forum suggested), reinstalled app, and now app appears to load, show thermostat, and works again.

  • Kev commented  ·   ·  Flag as inappropriate

    Ridiculous!!🤦🏾‍♂️ when will this app be updated? We all have the same freaking issues. Oops cant load the thermostat .

  • Anonymous commented  ·   ·  Flag as inappropriate

    I get an “oops not connected “ message when I trying using the thermostat function. Is there a fix for this problem?

  • Anonymous commented  ·   ·  Flag as inappropriate

    FYI.... for the people who are getting the error message OOPS NOT FOUND for controlling the Thermostat thru the app.... go to SETTINGS on you cell phone and clear the History and Cache.... if that don’t work .. uninstall the app .. then reinstall it.... it should work then

  • Anonymous commented  ·   ·  Flag as inappropriate

    Can someone from PEPCO IT department please fix the thermostat app... I’m getting a error message of OOPS NOT WORKING....

    Does anybody from Pepco read this message board????

  • AJ commented  ·   ·  Flag as inappropriate

    The Program Thermostat function from the App stopped working. It simply says ‘not found’. It’s very frustrating. How do we fix this ???

  • Adrienne commented  ·   ·  Flag as inappropriate

    Thermostat programming went out on Friday, 3/23/19. I called both of the emergency services phone numbers and left messages as I was never able to speak to a human being no matter which prompt I pressed. Today is Monday and I have not heard from anyone as of yet. That means we froze the entire weekend with no heat. Not amused. There are no props on the app or the website that even mention reprogramming the thermostat, much less allow you to do it. There is not a selection on the emergency call numbers for this type of problem.

  • Concerned patron commented  ·   ·  Flag as inappropriate

    I’ve called about this issue as few times and I’ll continue to post..PLEASE FIX THE PROGRAM MY THERMOSTAT on the app.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Only reason I wanted app was to easily program thermostat. Exercise in frustration! Almost every time I try to make a change there is an error, specifically no time appears.🤬 FIX IT!!!

  • Bfcav commented  ·   ·  Flag as inappropriate

    Where is the link to the thermostat on this app? This is just why I didn’t want an upgrade to a new thermostat.

  • Eric commented  ·   ·  Flag as inappropriate

    Technician installed programmable thermostat on 12/11; Said app would work in 48 hours. I can’t find how to program thermostat from the app. When I called tech support at 866-353-5798 (number installer gave if I was having a problem), I was told that Pepco had not yet activated my account to use the app. I was told to call Pepco at 202-833-7500. After working my way through the Pepco telephone tree, I reached a tech support who said I had to call the original help #. Needless to say, I am a bit frustrated. Any advice on what I should do now would be appreciated.

  • Jesd commented  ·   ·  Flag as inappropriate

    I am getting an error in the app when I try to go to the program thermostat page. I can log onto my account just fine. this started s week ago.

  • Shandra commented  ·   ·  Flag as inappropriate

    App is a waste of space on my phone. I only downloaded the app because I was told that O could control the thermostat from my phone with the new thermostat that was installed.

  • Anonymous commented  ·   ·  Flag as inappropriate

    PEPCO app is suppose to allow us to control the Thermostat but there is no link. As Technician advised to download the pepco app & click on one of the box "Program Thermostat " seems very easy but when I tried I don't see anything like that. This feature tempted me to get this Thermostat. So frustrating. PLEASE FIX IT.

  • Harry commented  ·   ·  Flag as inappropriate

    There's no link to My Thermostat on the Pepco Self-Service app.

  • Anonymous commented  ·   ·  Flag as inappropriate

    PEPCO app was supposed to allow us to control the thermostat. This was a feature that prompted us to get new thermostat. But the app does not allow for this. Please fix.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Just had the PEPCO wifi thermostat installed, but I can't see anywhere in the app to connect to the thermostat.

← Previous 1

Feedback and Knowledge Base